No electronics working in car - ClassicOldsmobile.com


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old August 10th, 2018, 06:09 AM   #1  
Registered User
Thread Starter
 
Join Date: Aug 2018
Posts: 1
No electronics working in car

Hello everyone i have a 1966 olds 98 that starts and runs but i have lost all electrical power to the car. Any suggestions on what it could be? Thanks
cr1114 is offline   Reply With Quote
Old August 10th, 2018, 06:59 AM   #2  
Old(s) Fart
 
joe_padavano's Avatar
 
Join Date: Mar 2007
Location: Northern VA
Posts: 29,666
Quote:
Originally Posted by cr1114 View Post
Hello everyone i have a 1966 olds 98 that starts and runs but i have lost all electrical power to the car. Any suggestions on what it could be? Thanks
If you had really lost ALL electrical power, it wouldn't even start, so there is partial loss somewhere. You need to carefully test circuits one-by-one and figure out exactly what works and what doesn't.

joe_padavano is online now   Reply With Quote
Old August 10th, 2018, 09:18 AM   #3  
Moderator
 
Olds64's Avatar
 
Join Date: Jul 2007
Location: Edmond, OK
Posts: 10,179
Before getting out your DVOM make sure you check the fuses.
Olds64 is offline   Reply With Quote
Old August 10th, 2018, 10:58 AM   #4  
Registered User
 
Join Date: Jul 2018
Location: Ontario Canada
Posts: 9
Sounds like you might have a break in the wiring coming from the junction box from the battery , if you have no power to the rest of the car
Luther99 is offline   Reply With Quote
Old August 10th, 2018, 12:58 PM   #5  
Moderator
 
oldcutlass's Avatar
 
Join Date: Oct 2009
Location: Granbury, Texas
Posts: 30,312
Quote:
Originally Posted by cr1114 View Post
Hello everyone i have a 1966 olds 98 that starts and runs but i have lost all electrical power to the car. Any suggestions on what it could be? Thanks
Do all the outside lights work including headlights?

Quote:
Originally Posted by Luther99 View Post
Sounds like you might have a break in the wiring coming from the junction box from the battery , if you have no power to the rest of the car
If you talking about the power stud on the horn relay, that's not it as the car runs. There is only one wire that goes into the car. Then it runs to a splice that branches out to feed three fuses, (the tail lights, courtesy lights, and stop lights), another branch feeds the ignition switch, and another feeds the headlight switch.
oldcutlass is online now   Reply With Quote
Old August 10th, 2018, 01:50 PM   #6  
Just an Olds Guy
 
Allan R's Avatar
 
Join Date: Jul 2008
Location: Edmonton, AB. And "I am Can 'eh' jun - eh"
Posts: 22,082
Quote:
Originally Posted by cr1114 View Post
........... i have lost all electrical power to the car......
Define this more clearly. It will help people understand your problem. Word your reply carefully so it "paints a picture' for the reader.
Allan R is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fry's Electronics ThePackRat The Clubhouse 9 February 10th, 2014 12:33 PM
Car Electronics Died Mid-drive? Joffroi Electrical 46 April 6th, 2012 05:47 AM
Car starts by dash electronics are dead glord General Questions 4 September 3rd, 2011 06:57 PM
need help with electronics (LEDs) jensenracing77 The Clubhouse 4 August 1st, 2011 08:00 PM
radios- electronics jcabbott13 Electrical 12 May 1st, 2009 03:53 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:48 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.