Well I bought another 63 F-85 - ClassicOldsmobile.com

Go Back  ClassicOldsmobile.com > Vehicle Lineup > Other Oldsmobiles
Well I bought another 63 F-85 >

Well I bought another 63 F-85

Other Oldsmobiles Anything not listed above, such as F-85 (1961-1963), Firenza (1982-1988), Starfire (1961-66 and 1975-80), Omega, etc.

Well I bought another 63 F-85

Reply

 
 
 
Old June 6th, 2018, 03:14 PM
  #1  
Registered User
Thread Starter
 
carbizguy's Avatar
 
Join Date: Feb 2017
Location: Redondo Beach, CA
Posts: 87
Well I bought another 63 F-85

So, my dads old car was in far worse shape than anticipated. I spent countless hours researching all the parts I needed and I finally came to the realization that it was just not cost effective. it was a major bummer.

So instead I began a search for a nice rust free donor, that was my intention anyway. I found one and it was the same color as my dads, it was solid so I bought it even though I probably spent more than I should've. This may be a driver instead.

It does have a few bugs to work out, most concerning is some white/blue smoke and the burning of oil. The previous owner said he spent $4000 on the motor rebuild. any ideas what to do first??

He also replaced the carburetor with a 500 cfm edelbrock. That seemed a little much to me and its not running right when its cold, then when it warms up it starts to smoke. He gave me the original 4 barrel Rochester that I planned on rebuilding, but I'm not sure what to do to solve this smoking problem.
Attached Images
File Type: jpg
f85.jpg (1,003.6 KB, 41 views)
File Type: jpg
00X0X_83PNelRVktB_1200x900.jpg (157.1 KB, 37 views)

Last edited by carbizguy; June 6th, 2018 at 07:56 PM.
carbizguy is offline  
Reply With Quote
Old June 6th, 2018, 05:53 PM
  #2  
Registered User
 
jensenracing77's Avatar
 
Join Date: Feb 2009
Location: Brazil Indiana
Posts: 9,394
I would look and see if they installed some kind of PCV on it and hooked it up wrong. It could be sucking oil through that. I believe that 63 was the first year for it on the Cutlass and F-85.

Looks like a nice car. A/C, power brakes, power steering...
jensenracing77 is offline  
Reply With Quote
Old June 6th, 2018, 06:08 PM
  #3  
Registered User
Thread Starter
 
carbizguy's Avatar
 
Join Date: Feb 2017
Location: Redondo Beach, CA
Posts: 87
Thanks, its way better than my other one. I'll check the PCV out.

do you think the 500 cfm edelbrock could be part of the problem when its cold? It sputters and coughs for a little while

Last edited by carbizguy; June 6th, 2018 at 06:10 PM.
carbizguy is offline  
Reply With Quote
Old June 6th, 2018, 06:16 PM
  #4  
Registered User
 
jensenracing77's Avatar
 
Join Date: Feb 2009
Location: Brazil Indiana
Posts: 9,394
I am the wrong guy to ask on carburetor issues. I can make a Jetfire 1 bbl carb work great but outside of that I am not very good with them.
jensenracing77 is offline  
Reply With Quote
Old June 6th, 2018, 06:24 PM
  #5  
Registered User
 
young olds's Avatar
 
Join Date: Mar 2010
Location: Mt Vernon,WA
Posts: 1,626
The 500 shouldn’t cause running issues if set up correctly, worst thing might be lack of throttle response. Check to make sure your choke and fast idle are set correctly
young olds is offline  
Reply With Quote
Old June 6th, 2018, 06:37 PM
  #6  
Registered User
Thread Starter
 
carbizguy's Avatar
 
Join Date: Feb 2017
Location: Redondo Beach, CA
Posts: 87
nice, thanks guys. I appreciate the insight. I'm not good with the mechanics part of it, so I will take this to my buddy who runs a local restoration shop. He said he grew up with the 215 and knows it like the back of his hand. fingers crossed
carbizguy is offline  
Reply With Quote
Old June 7th, 2018, 07:22 AM
  #7  
Old(s) Fart
 
joe_padavano's Avatar
 
Join Date: Mar 2007
Location: Northern VA
Posts: 30,260
I've got an E-brock 500 cfm on my 62 and it is not the cause of oil smoke.
joe_padavano is offline  
Reply With Quote
Old June 7th, 2018, 12:55 PM
  #8  
Registered User
Thread Starter
 
carbizguy's Avatar
 
Join Date: Feb 2017
Location: Redondo Beach, CA
Posts: 87
Thanks Joe, yeah I was more concerned the edelbrock may be causing my hesitation and sputtering when it's cold. I read on the HAMB that the 390 cfm was more ideal for this engine. I'm headed to my shop to see if he can get this all sorted out.
carbizguy is offline  
Reply With Quote
Old June 7th, 2018, 12:59 PM
  #9  
Old(s) Fart
 
joe_padavano's Avatar
 
Join Date: Mar 2007
Location: Northern VA
Posts: 30,260
Originally Posted by carbizguy View Post
Thanks Joe, yeah I was more concerned the edelbrock may be causing my hesitation and sputtering when it's cold. I read on the HAMB that the 390 cfm was more ideal for this engine. I'm headed to my shop to see if he can get this all sorted out.

That sounds more like a choke adjustment problem.
joe_padavano is offline  
Reply With Quote
Old June 16th, 2018, 10:06 PM
  #10  
Registered User
 
Join Date: May 2015
Location: Preston Idaho
Posts: 130
Not fired yet, but I have installed a fuel injection system on mine. Also fit a 69 Camaro fuel tank so I could have a wet fuel pump to keep noise down and better fuel delivery.
Attached Images
File Type: jpg
May 2018-1.jpg (62.1 KB, 13 views)
File Type: jpg
FI-3.jpg (107.4 KB, 9 views)
File Type: jpg
engine w relays-2.jpg (103.5 KB, 9 views)
File Type: jpg
FI-1.jpg (104.7 KB, 12 views)
Torqueline is offline  
Reply With Quote
Old June 25th, 2018, 08:34 PM
  #11  
Registered User
Thread Starter
 
carbizguy's Avatar
 
Join Date: Feb 2017
Location: Redondo Beach, CA
Posts: 87
thats very nice, can't wait to hear how it works out for you
carbizguy is offline  
Reply With Quote
Old July 18th, 2018, 08:35 AM
  #12  
Registered User
 
Join Date: Jul 2018
Location: Laguna Hills, Calif
Posts: 12
1963 F-85 Cutlass

I just bought a '63 F-85 and am in need of some parts.The letters on the trunk are missing as well as the front fender cutlass script and Olds "'T". any help would be great. Email: [email protected]. Thanks
hotrodsurfer is offline  
Reply With Quote
Old July 19th, 2018, 07:57 PM
  #13  
Registered User
Thread Starter
 
carbizguy's Avatar
 
Join Date: Feb 2017
Location: Redondo Beach, CA
Posts: 87
Nice, welcome! Not sure, I will see what I got.
carbizguy is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Tedd Thompson
The Clubhouse
4
January 3rd, 2016 11:07 AM
Dead Reckon
General Discussion
4
November 7th, 2014 05:30 AM
The Bug Man
Body work
0
August 15th, 2013 12:53 PM
young olds
General Discussion
13
September 1st, 2011 02:27 PM
justagirlfromla
General Discussion
15
October 6th, 2010 04:30 PM


Thread Tools
Search this Thread