ClassicOldsmobile.com  

Go Back   ClassicOldsmobile.com > Repair & Restoration > Engine > Small Blocks
Sign in using an external account
Register Forgot Password?
Search

Welcome to Classic Oldsmobile Forum!
Welcome to Classic Oldsmobile forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Classic Oldsmobile Forum today!


Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread Display Modes
Old March 7th, 2010, 11:50 PM   #1
Registered User
 
Join Date: May 2008
Posts: 19
Olds 350-1980 Cadillac Eldorado

Hey guys,

My mechanic just finished with my engine swap last week. Its a 1980 Cadillac Eldorado with the original 368 engine. The smallest of the big block Caddy's. I swapped it out for an Oldsmobile 350, 3b engine. The car has a TH325 tranny. Originally wanted a Olds 350 or a Caddy 425 in it. I got a hold of the 350 first, so that's what I went with. Anyway the car is similar to the Oldsmobile Toronado.

I have a problem with my shifter, it seems to only go into two gears...Neutral, and what I believe to be Drive in lowest gear setting. My car says *P *R *N *D *L (Park, Reverse, Neutral, Drive with two dots above it, and Low) Every position works except for Neutral and Drive positions. I mean, its like I have rock my shifter to get it in the position I want. But I can never really tell what position in Drive that I am. I don't know how many Drive positions these era cars have (1979-85 Toronados, Riviera's, and Eldorado's. I feel as though it only shifts into Drive-Low position. Why does the cars have two dots above the word Drive on the dash, and a seperate position called Low? is there three Drive positions? How can I fix my shifter so its tight and shows the correct position on the dash? I think all the bushings and stuff are deteriorated on the engine bay side of the shifter assembly. Can I buy aftermarket parts to fix this?

My engine is running poorly, not much power increase over the 368, although I heard that the 350 can be quite powerful, so I'm wondering what are the proper things to check for baseline performance? Is my quadrajet not working properly. I tried to burnout this morning and my wheels were locked (also its fwd), but when i hit the accelerator pedal the engine (in Drive) tried to go, but then almost immediately died...it did not die, but sounded like it was going to, then it just kind of roughly stayed running gurgling to try and give some rpm's, but was not able to. I think its a 1977-80 block, what are the most basic upgrades to be done? only looking for around 215-250 horsepower increase.

Thanks for all your help guys!
nitinnelapudi is offline   Reply With Quote
Old March 8th, 2010, 05:44 AM   #2
Registered User
 
Join Date: Nov 2008
Location: Central Fl
Posts: 3,193
215-250 horsepower increase.

Thanks for all your help guys![/quote]

You're looking for an increase of that or thats your total? Either way maybe you should have done that before you installed it.

Start with a basic tune up to see what your bogging may be. Then go from there. You may have done this backwards.
cutlassefi is offline   Reply With Quote
Old March 8th, 2010, 07:34 AM   #3
Registered User
 
Join Date: May 2008
Posts: 19
Yeah Sorry,

I meant a total of 215-250 horsepower. Yea I guess I must have done things backwards, but my mechanic and I were trying to see if the engine would even work in there, we knew it ran, but didn't know if we could get the right parts to make it fit....anything on the shifter problem?
nitinnelapudi is offline   Reply With Quote
Old March 8th, 2010, 07:58 AM   #4
Registered User
 
Join Date: Nov 2008
Location: Central Fl
Posts: 3,193
I'd ask some others on the shifter problem. As far as your target hp, a simple manifold and carb swap will take care of that. A Performer and 600 carb would work fine. Contact delta881972, he may have a carb for sale.
cutlassefi is offline   Reply With Quote
Old March 9th, 2010, 04:32 AM   #5
Registered User
 
Join Date: Sep 2009
Location: Braintree, Mass
Posts: 372
Those early 80's Eldorados were nice (if it didn't have the 4100). I missed out out a low milage olds powered eldo some time ago, I think it was fuel injected.
Destructor is offline   Reply With Quote
Old March 9th, 2010, 05:02 AM   #6
Landyacht Club President
 
Olds64's Avatar
 
Join Date: Jul 2007
Location: Lawton, OK
Posts: 7,336
You can double check your shifter by removing the linkage at the transaxle. Then move the shifter lever at the transmission manually without the linkage. This will tell you if you have all the gears working correctly in the transmission. Make sure you double check which side Park is on before you remove the linkage. This way you can put the shifter lever on the transmission back in Park before reataching the linkage.
__________________
1971 Oldsmobile 98
2011 Ford Flex
Olds64 is offline   Reply With Quote
Old March 9th, 2010, 05:44 AM   #7
Old(s) Fart
 
joe_padavano's Avatar
 
Join Date: Mar 2007
Location: Northern VA
Posts: 15,743
So the shifter problems started with the engine swap? If so, tell your mechanic to adjust it properly. I believe these cars have a cable from the steering column to the trans. It's possible the cable was either damaged during the swap or not reassembled correctly.
__________________
Joe Padavano

62 F-85 Deluxe wagon (the NV desert car)
62 F-85 Deluxe wagon (the San Jose car)
64 Vista Cruiser
64 Jetstar 88 Conv
66 442 L-69 Conv
68 W-30
69 H/O
69 442
70 W-30
72 442
84 Custom Cruiser
86 Caprice wagon (w/307 Olds)
joe_padavano is offline   Reply With Quote
Old March 9th, 2010, 05:15 PM   #8
Registered User
 
Join Date: May 2008
Posts: 19
No Joe, it happened even before the swqp, but i will tell you this, we couldn't use the cable shift, its a different type of shift mechanism, my mechanic had to fabricate a bracket to hold the shifter in place. i believe its a rod or shaft type shifter.
nitinnelapudi is offline   Reply With Quote
Old March 10th, 2010, 06:01 AM   #9
Landyacht Club President
 
Olds64's Avatar
 
Join Date: Jul 2007
Location: Lawton, OK
Posts: 7,336
Did you remove the linkage and see if the shifter worked properly at the transmission? There should 6 positions: Park, Reverse, Neutral, Drive, Second, and Low

If the shifter works properly at the transmission then you know the problem is in your linkage. Perhaps the mechanic that fabricated your linkage needs to adjust it.
__________________
1971 Oldsmobile 98
2011 Ford Flex
Olds64 is offline   Reply With Quote
Old March 10th, 2010, 06:01 AM
ClassicOldsmobile
1957 Oldsmobile




Paid Advertisement
 
 
 
submit to reddit
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1980 eldorado swap nitinnelapudi Major Builds & Projects 0 August 11th, 2009 01:40 PM
Cadillac man finding a new love... 82 Cutlass The Newbie Forum 22 June 16th, 2009 12:57 PM
1980 Olds Cutlass gscott819 General Questions 8 February 3rd, 2009 02:19 PM
Question about a Cadillac 472 dan2286 Other 1 July 25th, 2008 10:43 PM
1978-1980 Olds 350 short block marcam923 Parts Wanted 1 February 2nd, 2007 06:15 AM


All times are GMT -7. The time now is 04:44 PM.


Advertising - Privacy Statement - Terms of Service - Jobs
All content Copyright 2008 by Internet Brands, Inc.

Search Engine Friendly URLs by vBSEO 3.5.2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62