Speedometer not working - speedo drive gear - ClassicOldsmobile.com

Go Back  ClassicOldsmobile.com > Repair & Restoration > Other
Speedometer not working - speedo drive gear >

Speedometer not working - speedo drive gear

Speedometer not working - speedo drive gear

Reply

 
 
 
Old September 23rd, 2018, 06:28 PM
  #1  
Registered User
Thread Starter
 
Join Date: May 2018
Posts: 39
Speedometer not working - speedo drive gear

My speedometer stopped working suddenly yesterday.
I am able to turn the cable and see the speedometer as I do it.

Thus the drive speedo gear or the inner shaft speed gear is likely bad right?

What would cause either of these 2 gears to strip? I did shift down to low yesterday at low 10mph speed.... gently D to 2nd and then 2nd to Low. (TH350 automatic) . Driving in low seemed a little rough but cant tell for sure.

I dont want to go changing a plastic gear for it to just strip again if there is something causing this, that I have another issue.


Thanks in advance for input.
Via3d is offline  
Reply With Quote
Old September 23rd, 2018, 07:33 PM
  #2  
same but different
 
don71's Avatar
 
Join Date: Jun 2007
Location: Central Missouri
Posts: 2,297
The cable is stamped into a square shape and fits in the gear. I'd suspect that the female end of the driven gear has gotten worn more so than a stripped gears scenario. But it could happen. You're going to have to have a look and see. Pretty easy to repair....er replace.
don71 is offline  
Reply With Quote
Old September 23rd, 2018, 10:42 PM
  #3  
Old(s) Fart
 
joe_padavano's Avatar
 
Join Date: Mar 2007
Location: Northern VA
Posts: 30,249
Actually the root cause is usually a bad speedo cable. This causes excessive drag on the gears, and one or both wear out.
joe_padavano is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
O-dawg
Cutlass
1
November 3rd, 2016 06:07 AM
Uncle Hulka
Transmission
0
April 21st, 2014 05:37 PM
tmaleck
Transmission and Driveline
0
September 23rd, 2013 01:47 PM
sbFALL63
Transmission
1
November 18th, 2012 10:51 AM
one4theroad
Transmission
1
March 18th, 2010 11:31 PM


Thread Tools
Search this Thread