Lectric Limited review - ClassicOldsmobile.com

Go Back  ClassicOldsmobile.com > General > General Discussion
Lectric Limited review >

Lectric Limited review

General Discussion Discuss your Oldsmobile or other car-related topics.

Lectric Limited review

Old February 5th, 2019, 10:55 AM
  #1  
Registered User
Thread Starter
 
jensenracing77's Avatar
 
Join Date: Feb 2009
Location: Brazil Indiana
Posts: 9,610
Lectric Limited review

.....I edited the below info because I clearly looked at a wire wrong......

I have now had three orders from Lectric Limited. The first order was in 2014/2015 and was for an engine harness and forward light harness. Lucky for me, on that car I tested every single part possible as the car went together. Well, I tested the forward lights and things to do with that harness and had a light problem. I found that the ground in the harness had a terminal that did not have the insulation stripped before crimping. I had about 3 hours in finding the problem. I called them to let them know what I found and give them the lot number and even pictures for their records. I fixed it and that was the end.

Second order was a set of plug wires and that order was perfect. No issues at all.

This third and most recent order I got every harness for a 70 442. I noticed right off that a wire was loose and that it came out of the wiper motor terminal. No big deal, I just grabbed a correct terminal and crimped a new one on it.

Other than the issues I have found I am very pleased with the quality of everything else. Just undecided if I would use them again. What are you guys using and were you happy?

Last edited by jensenracing77; February 5th, 2019 at 02:30 PM.
jensenracing77 is offline  
Old February 5th, 2019, 11:19 AM
  #2  
Registered User
 
Join Date: Feb 2009
Posts: 1,946
Exclamation

To me, that is an egregious mistake. The wiring diagrams and wiring construction has not changed in decades.

To get something like that is unacceptable, and a PIA to have to replace.

I use M&H exclusively - their quality is A+
My442 is offline  
Old February 5th, 2019, 11:52 AM
  #3  
Moderator
 
Olds64's Avatar
 
Join Date: Jul 2007
Location: Edmond, OK
Posts: 10,509
I had a set of battery cable made for my 86 f250 at a local electrical supply shop. About a month after installing the cables a terminal separated from one of the negative battery cables!

I called the shop that made them and they said they would fix the battery cable. The only problem was that I would have to remove the cable and bring it to them. Luckily, it was a negative battery cable and not the crossover positive battery cable. That would have been a PITA to remove.

Ultimately, they corrected the problem and were very friendly and apologetic. Even though it was a bit of a hassle I plan on having them make some battery cables for my Olds in the future.
Olds64 is offline  
Old February 5th, 2019, 12:18 PM
  #4  
Registered User
 
mrolds69's Avatar
 
Join Date: Jul 2010
Location: Toytown, MA
Posts: 1,161
I could be wrong here, but my understanding is, or was, that American Autowire was presently making all this stuff for the other companies and they were just re-marketing it. I know at one time, M+H made their own harnesses. I know Lectric Limited makes some specialty stuff. I either read this or saw this someplace......
mrolds69 is online now  
Old February 5th, 2019, 01:25 PM
  #5  
Registered User
 
rand5204's Avatar
 
Join Date: Mar 2012
Location: Cumming, GA
Posts: 542
I have used only American Autowire harnesses on my cars and have never had a problem.
rand5204 is offline  
Old February 5th, 2019, 01:47 PM
  #6  
Registered User
Thread Starter
 
jensenracing77's Avatar
 
Join Date: Feb 2009
Location: Brazil Indiana
Posts: 9,610
Update coming, May not be a problem with the starter wire
jensenracing77 is offline  
Old February 5th, 2019, 02:05 PM
  #7  
Registered User
 
mrolds69's Avatar
 
Join Date: Jul 2010
Location: Toytown, MA
Posts: 1,161
Sure, could be the right gauge actual wire but less plastic insulation. I've seen that before.
mrolds69 is online now  
Old February 5th, 2019, 02:27 PM
  #8  
Registered User
Thread Starter
 
jensenracing77's Avatar
 
Join Date: Feb 2009
Location: Brazil Indiana
Posts: 9,610
Yes, I am going to have to edit my original post. It does have the correct wire in it. I am going to have to get my eyes checked and apologize to Lectric Limited.... The other issues were for sure still an issue.
jensenracing77 is offline  
Old February 5th, 2019, 08:20 PM
  #9  
Registered User
 
Join Date: Jun 2008
Location: Chicago
Posts: 1,025
Iíve had good luck with M&H and Lectric Limited. All my harnesses for the car came from M&H. My rear light harness from M&H had a socket assembled wrong that I fixed. Other than that I was impressed with fitment and function. Iíve gotten sending units, T3 headlights, and other miscellaneous pieces from Lectric Limited and had no issues.
83hurstguy is offline  
Old February 5th, 2019, 08:48 PM
  #10  
Registered User
 
steverw's Avatar
 
Join Date: Dec 2012
Location: Texas
Posts: 1,547
I have used Lectric Limited harnesses on my Olds and Vette, so far they have been great.

Steve
steverw is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
35tac
Buyer & Seller Feedback
0
December 16th, 2017 06:54 PM
auto_editor
Drivetrain/Differentials
3
March 11th, 2014 09:32 AM
68rocketred
Parts Wanted
2
April 25th, 2008 07:38 PM
timswife79
Cars For Sale
0
February 8th, 2007 11:05 AM


Thread Tools
Search this Thread
Quick Reply: Lectric Limited review


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.