Go Back  ClassicOldsmobile.com > Repair & Restoration > Electrical
87 Cutlass Blower only works on high - NOT resistor >

87 Cutlass Blower only works on high - NOT resistor

87 Cutlass Blower only works on high - NOT resistor

Old December 4th, 2018, 12:34 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2010
Location: Roanoke, VA
Posts: 166
87 Cutlass Blower only works on high - NOT resistor

I swapped in a new resistor based on lots of posts suggesting that was the culprit. My blower motor only works on high- well sort of... it also seems to have a mind of itís own, a couple times with all controls in the off position it started working at what I believe to have been lower speeds all on its own. In those instances I could cut the car off and get out with keys in hand, the blower would still be running- any help is appreciated
grmchne78 is offline  
Old December 4th, 2018, 12:42 PM
  #2  
Registered User
Thread Starter
 
Join Date: Jul 2010
Location: Roanoke, VA
Posts: 166
Maybe I should stress, a new resistor made no difference
grmchne78 is offline  
Old December 4th, 2018, 02:42 PM
  #3  
Olds Fever
 
CRUZN 66's Avatar
 
Join Date: May 2011
Location: New York (Upstate)
Posts: 3,125
I suggest checking the blower relay and/or the connector to the relay...
CRUZN 66 is offline  
Old December 5th, 2018, 01:58 AM
  #4  
Registered User
 
Join Date: Jan 2010
Location: central Indiana
Posts: 1,130
The resistor is functional only on the lower speeds. If you have high only, check the relay. It bypasses the resistor block and supplies full battery voltage to the blower motor.
matt69olds is online now  
Old December 6th, 2018, 04:31 AM
  #5  
Registered User
Thread Starter
 
Join Date: Jul 2010
Location: Roanoke, VA
Posts: 166
The relay fixed it, thanks!
grmchne78 is offline  
Old December 6th, 2018, 02:46 PM
  #6  
Olds Fever
 
CRUZN 66's Avatar
 
Join Date: May 2011
Location: New York (Upstate)
Posts: 3,125
Originally Posted by grmchne78 View Post
The relay fixed it, thanks!
Good to hear you were able to fix the problem...
CRUZN 66 is offline  
Old December 7th, 2018, 06:13 AM
  #7  
Registered User
Thread Starter
 
Join Date: Jul 2010
Location: Roanoke, VA
Posts: 166


Some call me hard headed but I drive my cars, my every day car is this 87 Cutlass everything works, good heat, ac, tilt, delay wipers, good sound system. It does everything a new car does at virtually no cost. Iím 52 and never made a car payment for my transportation. I have always tried to get my wife a newer car for her safety and reliability. My Olds is a great car and I would take it anywhere right now. It has 200K and I ainít scared!
grmchne78 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jon442
Electrical
2
January 30th, 2018 01:33 PM
96powerstroke
Electrical
7
September 11th, 2016 05:38 AM
Octania
The Clubhouse
11
March 11th, 2016 07:08 AM
mhood
Electrical
2
August 12th, 2011 10:18 AM
Luckyme1870
Aurora
1
July 26th, 2007 05:05 AM


Thread Tools
Search this Thread
Quick Reply: 87 Cutlass Blower only works on high - NOT resistor


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.